"Freeze" sur le forum et consommation RAM

Les questions auxquelles seul Nicolas a la réponse

Modérateur : copain des copeaux

Kob
Habitué
Habitué
Messages : 45
Enregistré le : Jeu 19 Mai 2016 13:58

"Freeze" sur le forum et consommation RAM

Messagepar Kob » Mar 10 Oct 2017 10:18

Bonjour,

Depuis quelque temps, quand je navigue sur le forum, la page "freeze" légèrement quand je la défile et l'onglet du navigateur consomme énormément de RAM (plus de 1,5Go et 25% d'utilisation du processeur).

Je pense qu'il doit y avoir un script qui ne doit pas fonctionner correctement.

Ça me le fait avec deux PC différent et avec deux navigateurs différents et ça me le fait uniquement avec ce forum.

Avatar de l’utilisateur
alrj
Accro
Accro
Messages : 221
Enregistré le : Mar 21 Avr 2015 08:10
Localisation : Belgique

Re: "Freeze" sur le forum et consommation RAM

Messagepar alrj » Mar 10 Oct 2017 10:40

(Note aux modos: il faudrait peut-être fermer la section "Questions à Nico" ?)

Moi ça me le fait aussi avec Chromium (sur deux machines), mais pas avec Firefox. D'après le profiler, c'est le "Painting" qui prend tout, principalement en "Composite Layers".
Je me demande si ça n'est pas plus une question de CSS que de javascript.

Avatar de l’utilisateur
alrj
Accro
Accro
Messages : 221
Enregistré le : Mar 21 Avr 2015 08:10
Localisation : Belgique

Re: "Freeze" sur le forum et consommation RAM

Messagepar alrj » Mar 10 Oct 2017 10:55

Apparemment, c'est un bug de webkit sur les éléments qui ont une position "fixed", qui cause un repainting complet à chaque étape du scroll.

Si je réduis la largeur de la fenêtre de mon navigateur pour que l'image de fond ne soit plus visible, la page défile de manière fluide.
Si je désactive le mode "fixed" sur l'image de fond (depuis les outils de dev de Chromium), la page défile de manière fluide.

Kob
Habitué
Habitué
Messages : 45
Enregistré le : Jeu 19 Mai 2016 13:58

Re: "Freeze" sur le forum et consommation RAM

Messagepar Kob » Mar 10 Oct 2017 12:19

alrj a écrit :(Note aux modos: il faudrait peut-être fermer la section "Questions à Nico" ?)

J'ai trouvé que c'était la catégorie la moins inadapté pour poster mon sujet.

alrj a écrit :Moi ça me le fait aussi avec Chromium (sur deux machines), mais pas avec Firefox. D'après le profiler, c'est le "Painting" qui prend tout, principalement en "Composite Layers".
Je me demande si ça n'est pas plus une question de CSS que de javascript.

Ou alors Nico nous fait miner des Bitcoins pour payer l'hébergement du forum:
https://korben.info/generer-de-cryptomo ... -idee.html

:-)marteau

Avatar de l’utilisateur
FastAndDirty
Accro
Accro
Messages : 654
Enregistré le : Jeu 12 Mai 2016 19:36
Localisation : 78

Re: "Freeze" sur le forum et consommation RAM

Messagepar FastAndDirty » Mar 10 Oct 2017 12:24

effectivement, j'avais constaté le même soucis et la fluidité est sans pareille quand on prends le navigateur dans une "petite" fenêtre", avec aucune image de fond visible (Win 7 / Chrome)

Avatar de l’utilisateur
alrj
Accro
Accro
Messages : 221
Enregistré le : Mar 21 Avr 2015 08:10
Localisation : Belgique

Re: "Freeze" sur le forum et consommation RAM

Messagepar alrj » Mar 10 Oct 2017 12:46

Kob a écrit :
alrj a écrit :(Note aux modos: il faudrait peut-être fermer la section "Questions à Nico" ?)

J'ai trouvé que c'était la catégorie la moins inadapté pour poster mon sujet.

Ah mais je suis d'accord avec toi ! Forcément, la catégorie "Fonctionnement du forum" est fermée... :-)marteau

Sinon, il reste les sujets n'ayant rien à voir avec la menuiserie.

Puligny
Découvre le forum
Découvre le forum
Messages : 1
Enregistré le : Mer 24 Mai 2017 09:58

Re: "Freeze" sur le forum et consommation RAM

Messagepar Puligny » Mar 10 Oct 2017 12:58

En fait, le problème est connu sous chrome uniquement.
C'est l'image de fond (background) par CSS qui fait ramer le scrolling. J'ai essayé de la bloquer par adblock mais en vain...

Il suffit d'enlever ce background par la fonction "INSPECTER" de chrome pour se rendre compte de la différence:

Image

Pas moyen d'enlever cette image de fond ou de changer le style du forum ?

Avatar de l’utilisateur
ced68270
Fan
Fan
Messages : 106
Enregistré le : Dim 28 Fév 2016 16:39
Localisation : haut rhin

Re: "Freeze" sur le forum et consommation RAM

Messagepar ced68270 » Mar 10 Oct 2017 21:06

pareil depuis quelques temps la page rame quand tu la défile
travaille a l'électroportatif et outils manuels (mini atelier)
fait des assemblage avec la lamelleuse

krusaf
Fan
Fan
Messages : 96
Enregistré le : Mar 13 Déc 2016 14:19

Re: "Freeze" sur le forum et consommation RAM

Messagepar krusaf » Mer 11 Oct 2017 23:10

Bonjour à tous,

On prend note du sujet :)

Galip
Accro
Accro
Messages : 418
Enregistré le : Mar 17 Mai 2016 19:45

Re: "Freeze" sur le forum et consommation RAM

Messagepar Galip » Dim 15 Oct 2017 10:05

Sous Chrome aussi ced68270 ?
J'ai pas de soucis sous FF en tout cas.

Quoi qu'il en soit vous pouvez supprimer l'affichage de l'image de fond sur votre navigateur.
- cherchez et Installez l'extension Stylish
- appuyez sur le bouton de l'extension et choisissez "créer un nouveau style pour : copaindescopeaux..."
- insérez avant la dernière accolade fermante ceci : body {background-image : none ;}
- enregistrez le nouveau style

et si les rabots indiquant les rangs de posteur vous soulent vous pouvez insérer également : dd.profile-rank img {display: none;}
Débute avec outils manuels...

Avatar de l’utilisateur
ced68270
Fan
Fan
Messages : 106
Enregistré le : Dim 28 Fév 2016 16:39
Localisation : haut rhin

Re: "Freeze" sur le forum et consommation RAM

Messagepar ced68270 » Dim 15 Oct 2017 21:48

oui sous chrome
travaille a l'électroportatif et outils manuels (mini atelier)
fait des assemblage avec la lamelleuse

Galip
Accro
Accro
Messages : 418
Enregistré le : Mar 17 Mai 2016 19:45

Re: "Freeze" sur le forum et consommation RAM

Messagepar Galip » Lun 16 Oct 2017 10:24

En effet ça rame :/

J'ai testé la manip avec Stylish sous Chrome, il suffit d'insérer le bout de code dans la zone (il n'y a pas de code déjà présent, donc pas d'accolade...), et ça règle le soucis de lenteur.
Débute avec outils manuels...

Avatar de l’utilisateur
alrj
Accro
Accro
Messages : 221
Enregistré le : Mar 21 Avr 2015 08:10
Localisation : Belgique

Re: "Freeze" sur le forum et consommation RAM

Messagepar alrj » Lun 16 Oct 2017 14:47

Et comme c'est plus sympa avec l'image de fond, et qu'il suffit qu'elle scrolle avec le reste de la page pour que ça ne rame pas, on peut mettre ceci dans stylish au lieu du code donné plus haut:

Code : Tout sélectionner

body {background-attachment : scroll ;}

Galip
Accro
Accro
Messages : 418
Enregistré le : Mar 17 Mai 2016 19:45

Re: "Freeze" sur le forum et consommation RAM

Messagepar Galip » Mar 17 Oct 2017 06:57

Parfait, comme ça y'a le choix ;)
Débute avec outils manuels...


Retourner vers « Questions à Nico! »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité